Jump to content
Delgado900

Specna arms H-05 FPS issue

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

Hi guys,

 

Starting a new thread on this.

 

I was impatient waiting for Patrol Base to have the Specna Arms H-05 in stock so I ordered it from Gunfire who were super quick.

 

I knew I would have to change the spring to lower the FPS (spare spring in the box stating 310fps). So I changed over the spring and it felt a bit weak, chrono’d it and it was running at 285fps hop was fully on so expected it to be lower than 310fps.

 

So I read somewhere that the lowering spring was a m90 spring. So I thought I’d pop out today and buy a m100 spring to increase the FPS to hopefully around 330-350fps. Changed over the spring now I’m at 405fps ..... help 

 

 

Share this post


Link to post
Share on other sites

What spring brand was it?  Sounds to me like you may have a M120 there but each brand is different in how they rate springs.

 

What FPS were you getting before you changed to the included M90?

 

Worth checking the hop chamber and bucking for any misalignment / damage.

Share this post


Link to post
Share on other sites

It’s firing straight as anything. 

 

Before lowering to the m90 spring it was firing at 430fps 

 

so the spring i went out any purchased today was an SHS m100 but the spring tension between the two were polar worlds apart so I’m thinking that the spring may have been packaged incorrectly. 

 

Any way to determine a spring from the coil rotation pattern? 

Share this post


Link to post
Share on other sites

I've noticed this with SHS springs now and then.  M110 tend to go M100 packaging and in some M110 you find M120's.  M110 and M120 look very similar,

 

Post a pic of the spring and I'll see if I can eye-ball it for you.  I've spent so long looking and testing these springs lol

Share this post


Link to post
Share on other sites

Ok so the attached photos 

 

shs m100 that feels super toight 405fps

 

Then we have the spring that came installed which was chucking out 430fps 

 

I’m going to run it at as is on Sunday and will take my old faithful rifle just in case 

F83D9FE3-ED39-422C-A8A6-2A2E56ABC440.jpeg

320101F4-0B26-41AC-84E8-146CA5437C93.jpeg

image.jpg

Share this post


Link to post
Share on other sites

Definitely a M110 or a M120 buddy.  If you want I can send you a ZCI M100 out today which are dead on from my tests.  Should get to you tomorrow 🙂

Share this post


Link to post
Share on other sites

Ahh man I felt like it was too tough putting it in ! 

 

Oh you hero, how much do you want for it? 

Share this post


Link to post
Share on other sites

Spring received, will post FPS results later!  Thanks @ak2m4 

Share this post


Link to post
Share on other sites

Ok so.... drumroll 

 

spring changed 343fps 

 

happy with the results 🤓

 

 

 

 

5F2700E4-65AF-4698-9E8B-53A968CFA46D.jpeg

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...