Jump to content
Sign in to follow this  
LazzurusMan

CM16 not feeling right.

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

So I bought a second hand cm16 the other day, and she doesn't seem to feed right. The first few rounds won't fire, and when I take the mag out about 5 bbs will fall out the mag well. Is this a common problem? I'm thinking it might berthed mag as the other pmag I got didn't have this problem, only the last two or three wouldn't feed.

Share this post


Link to post
Share on other sites

What ammo are you using?

And having a few bbs fall out when you remove the mag is perfectly normal with AEGs.

Share this post


Link to post
Share on other sites

think you kinda answered your own question there.....

1 mag feeds - other one don't

 

could try a little bit of felt/tape/velcro in magwell but could be a [email protected] old mag with crap spring

happens a bit - always remove bb's & empty mag when done for the day

 

and I'm sure peeps have got some really nice great mags that feed lovely in their guns plus a few that don't

on occasions those iffy mags may feed better in some other guns but not others

 

could try other bb's & tape in magwell but quite likely mag is a bit borked - for that gun anyway

(probably spring is worn & not supplying enough pressure to feed bb's very well)

 

main thing is gun ok - mags are easy/cheap to replace

 

I got some mid-caps and some hi-caps that are not so great at feeding,

some are ok then crap after halfway mid-caps

and some hi-caps that feeds about 5 or 6 bb's then need loads of winding

(really need to either see if I can fit new spring/stretch it a bit but most likely should just bin most of them)

Share this post


Link to post
Share on other sites

Problem with the mag, thankfully nowt wrong with the gun itself. Yep rounds always fall out, normal with standard AEGs, unless you buy magazines with extended follower things (although not all will work - RM4 ones only work with the RM4 for example) or certain hop up units.

Share this post


Link to post
Share on other sites

There was velcro in the mag well when I got it

That says to me that the previous owner had the same issue.

Share this post


Link to post
Share on other sites

Some mags work better than others, I ended up with 16 mid caps and only 6 work properly :blink:

 

Tend to use the high cap which came with the gun tho

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...