Jump to content
Sign in to follow this  
KiwiBanany

Gun firing only 1/5 trigger pulls

Recommended Posts

Hey guys,

 

At today's skirmish i encountered a rather strange problem. First,game, all 4 Kings Arms midcaps and my G&G G-MAG (high cap) all fed fine. I went back to the safe zone, re armed, and headed out for the second game. I loaded my G-MAG into the gun and shot some guys, all was swell. Then, it stopped :blink: . I wound the mag up and fired - nothing. I took the mag out, checked the hopper - almost full. Strange i thought, but i was in too good a position to worry and just loaded my next mag. The next 4 mid caps i loaded would only then fire once every five shots on average, give or take.

I called myself out, and went to speak to the Marshall. He adjusted my hop, i loaded my high cap and it went well for about 30-40 rounds, before the same happened again. Thinking this was really, really impracticable in a game that relies on shooting people, i went to the safe zone and talked to the tech. He just simply loaded a MAGPUL pts mag (high cap) and it worked fine. I borrowed this for the rest of the day and it worked perfectly - no issues whatsoever. However, when i loaded all 5 other mags, none of them would consistently shoot, only allowing a few rounds out here and there. I tried full auto and semi, even burst with no prevail.

 

My mate also tried 1 of the mid caps and it didnt feed well for him either.

 

Is it not strange how all 5 of my mags stop working at the same time, but a different mag will? Ive used the other mags on 3-4 skirmishes and they have all been fine.

 

I was using zeroone 0.25g bbs for all my mags and the one i borrowed.

 

Help!? :unsure:

Share this post


Link to post
Share on other sites

Is it still doing it now? Have you tried pushing the mags up into the gun whilst firing?

It is and that was the first thing i tried! hmm

Share this post


Link to post
Share on other sites

You don't leave your mags loaded throughout the week do you?

Share this post


Link to post
Share on other sites

You don't leave your mags loaded throughout the week do you?

nope

Share this post


Link to post
Share on other sites

Spent a few hours going through all the new G&G rental guns at my local site, and its a problem with the hop unit on all of the new design ones. Simple answer, you need to replace the hop unit completely, the unit is now made of a much softer plastic than they used to use, and the bit that engages the mag gets deformed too easily, and doesn't even engage it with some mags as its too short.

 

We systematically replaced all the hop units with the metal lonex one along with a lonex hop rubber and sure enough, they have had no problems with any mag type since. One thing though, if you do do this, use the stock g&g barrel clip, yet to find a gun where the lonex one will actually fit in the receiver, courtesy of the pointless reinforcing strips on the outer diameter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×