Jump to content
Gargamel

E&L ak47, i'm going to explode!

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

I bought E&L 104 gun. It was going to be LCT or E&L and i went with this, because of a lot of good reviews.

 

I got it today. Looked good but then...

 

I can't open battery compartment. Button feels loose, but it doesn't move forward much. What can i do? I can only destroy it to open it.

 

Second. Magazine doesn't open. Not even with a screwdriver. Any thoughts there?

 

The third one is on me. I managed to insert magazine sort of half way. At front it isn't in, at the back it is, but without thw click, so the release button is still pressed. Magazine is loose but i can't get it out.

 

Very unhappy :(

Share this post


Link to post
Share on other sites

I managed to open it, but in the process to little retainers of the button broke off. Then i checked why the button didn't move. Looks like a little piece of a wire that holds a spring was broken at the other end and basically jammed everything. Now what do i do? If i put he wire back in without this little broken off piece, the button still doesn't move + nothing holds it down anymore (because retainers broke off during opening) so nothing will hold the battery cover on. What can i say...ANY help would be nice.

 

Oh and i still can't get the magazine out...:(

 

post-10223-0-05229100-1412793354_thumb.jpg

 

post-10223-0-34595900-1412793364_thumb.jpg

 

post-10223-0-12689200-1412793375_thumb.jpg

Share this post


Link to post
Share on other sites

Well i learned how to strip the gun before i even fired my first shot :)

 

E&L bend the wire which the button should push to open the cover. Because of a bend, wire was broken and jammed so button couldn't move.

 

I straightened the wire and luckily it is still long enough to fit so button now works. But retainers are still broken of course and everything falls off. I'll superglue them on to see how it holds.

Share this post


Link to post
Share on other sites

TBH I think you should have sent/taken it back immediately because that looks to me very much like you've FUBAR'd it.

 

I'm trying hard, but I can't actually imagine how you broke the end off the rod?

 

To unjam the mag you might try some oil, which may have helped elsewhere also. But I think perhaps you may be better to avoid risking doing any more damage by doing it yourself and let a gun tech sort it out, either at wherever you bought it, or by hiring someone local to you.

Share this post


Link to post
Share on other sites

I'd agree with Ian & ikarma. If it's new then send it back,no point in Messing it up more since it's a lemon.

 

Shame you've had a bad experience,especialyl considering the price,but luck of the draw as per usual with ACM. Hell,luck of the draw often comes with 'premium' brands like LCT- Ian_Gere had an LCT AK that was rather sh*tty

 

Also,the stuck mag is caused by rocking it in wrong IIRC,did you insert the front of the mag into the forward bit of the well first or did you rock the rear in first? I made this mistake before but It was remedied with a hammer,by knocking the bottom of the mag back. Damaged the front lip but I got it out. I'd stress to just return the gun however-Don't deal with new Lemons.

Share this post


Link to post
Share on other sites

How do you open Lct 70 round steel ak47 magazine? It doesn't look like it has any doors?

 

You dont open it, Its a mid cap. Its loaded with a speed loader into the feed tube.

Share this post


Link to post
Share on other sites

E&L provides 400 round magazine which looks the same as Lct one so i guess i need to fill it with speedloader too. What i don't understand is that instruction manual shows a door to fill in and door on the bottom to pull out a string and pull it couple of times.

 

Looks like they changed that to speedloader system which doesn't need winding, right?

Share this post


Link to post
Share on other sites

^^Yeah, the 400rnd one with the door and string you are describing is a 'flash mag' and if the one supplied does not have that door, or a winder, it is a mid cap which requires a speed loader.

 

I didn't break the end of a rod. It was already broken because E&L jammed it in a hole and the end of a rod was bend so it was under a lot stress.

Well, let us hope that the retailer accepts that it was like that and replaces it, because you should not have to repair something which was broken when you received it. My worry is that, now you have dismantled it and have several broken pieces, the retailer may claim that you broke it and refuse to honour any warranty.

 

The thing is, the way most AK's are assembled, that rod is supposed to fit into a slot in the side of the barrel base assembly containing a spring, which is then covered along the side by the receiver, so it makes a hole into which the end of the rod fits - it is by pushing against this spring that the top cover latch/button, on the other end of the rod, is depressed, which then allows the top cover to be lifted off.

 

I am afraid that the way you have described it, it sounds very much like you did misunderstand something and did break it.

Share this post


Link to post
Share on other sites

It is possible that by pressing the button to open battery cover the rod tip broke off. But that happened because last 3 cm of that rod was bent and was stuck to the side of a hole. So that made it impossible to press the button to open a cover.

 

What i possibly did, was going crazy, pressing too much and tip of a rod broke off plus both retainers that hold this putton down broke off too.

 

So that was my mistake, but i just didn't think about sending it back to retail shop in other country just because of a silly button.

 

The situation now is i managed to free a magazine, i straighten the rod (i checked videos online, it SHOULD be straight) and luckily it is not too short now, so it fits. And i superglued 2 tiny retainers of a button that broke of (for a gun that should be tough to destroy those little retainers are funny but there isn't much movement up/down of a button so i guess it is ok). Looks like it works now with no problem. And i know this gun much better now.

 

I did sent a message to retail shop and i'll see what they say, but even i they refuse to help, i managed to solve the problem. But i do expect they will understand the rod being bent by manufacturer, because there is no way i could do that by pressing a button.

Share this post


Link to post
Share on other sites

Ahhh, that makes more sense now. There must have been an extra bit hanging off the end of the rod, partially cut but still attached well enough to get stuffed into the hole. Because, as you say, just pressing the button couldn't break that rod - just no way!

 

The end of the rod does not look right. You can tell that it was not finished correctly, so hopefully showing the retailer a picture of it will convince them to send you a new rod and button. When you say "retainers" do you mean the flanges on top of the gearbox which the latch/button fits between? Because, if you do, I don't think super glue will hold it - you will need a whole new gearbox shell...

Share this post


Link to post
Share on other sites

Yes flanges. English is not my first language, sorry. For now it looks like it holds it. Time will tell i guess. I don't know what other glue could i use. It looks like shell is aluminium. I don't think you can buy extra gearbox shell only. The whole unit is expensive.

Share this post


Link to post
Share on other sites

Yes, I guessed that English is not your first language and attempted to use less idiomatic language and/or contractions - your English is pretty good though.

 

I honestly do not think that any kind of glue will suffice and, when the glued bits fall off, they may get jammed in the fire selector mechanisms. Can you tell if there is anything special about the E&L gearbox design? If not, a V3 shell need not be that expensive at all.

 

I am not at home for a few days so I cannot take detailed measurements of some standard V3 gearboxes, but over the weekend I could do. This will allow you to check whether yours is compatible and, if not, if a standard shell can be modified to work with the E&L design gun. Of course, if anyone else reading this has the inclination to help, that could save some time.

 

Nonetheless, the damage has occurred as a result of a faulty part, so no matter how expensive, the retailer ought to replace the gearbox shell. Did you buy it from gunfire.pl?

Share this post


Link to post
Share on other sites

Hard to say. It looks very close to LCT for example. But i don't have much experience with other guns.

 

Yes, i bought it on gunfire.pl. No answer from them yet.

Share this post


Link to post
Share on other sites

Well, keep us posted - it will be informative for those of us who buy from Poland regularly and also those who are concerned about their customer service when considering buying from them. They do have to compete with taiwangun.com, who are also Polish, though and twg's customer service is excellent.

Share this post


Link to post
Share on other sites

This costumer service thing will be interesting. I sent them 3 mails (i know i'm annoying).

 

When i couldn't open a gun and button didn't work i sent them mail about the problem. That was 2 days ago. Today i got the answer to try to push harder...Well that is usefull.

I sent them one more mail later when i did open the cover and found out why button didn't work. But in the process of openning it something else broke. No answer for that yet..i guess they are really behind in answering mails.

Share this post


Link to post
Share on other sites

"Push harder" :lol:

 

Maybe they are also midwives!

Share this post


Link to post
Share on other sites

Interesting fact. I was shooting the gun a little bit with cover on but without button and rod. After half magazine, gun stopped shooting. Triger was dead, like battery wasn't there.

I tested the battery but it was full so i thought another thing stopped working in this gun and i was close to going balistic. But then i found out that the cover must be on 100%, if it is not and is lifted by cabels, or button fails for example it cuts power from battery. This looks like a safety thing so that you can't shoot without cover.

 

Interesting. Do other Aeg's have the same safety solution?

Share this post


Link to post
Share on other sites

I don't know. I move no connections when i push cover up or down.

 

Still i'm waiting for the answer of tech department of gunfire.pl. I have notified E&L too and they look intersted in this case, so we will see.

Share this post


Link to post
Share on other sites

Well 1 week has passed and i still didn't get no answer from gunfire.pl about my issue.

The only answer was, that mail was forwarded to tech department and that was it. I sent official complaint via a form from their website but still nothing.

 

I think 1 week is way overdue for an internet business to at least respond on this complaint.

 

Any idea what can i do? Does anyone know any other mail contact with the manager?

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...