Jump to content
uniweekendwarrior

WE Hi-Capa Dragon Problems

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

Hi all, I have a WE 5.1 Hi-Capa Dragon with a fault. When I fire the gun the first bb fires but then it only goes about a cm back on the blow back and proceeds to empty all the gas out the barrel. The magazine isnt the issue its been checked all good so any thoughts?

 

thanks in advance

Share this post


Link to post
Share on other sites

Umm, not sure, but this shouldn't be here, it should be in the gas problems section further down the home page

Share this post


Link to post
Share on other sites

What gas are you using?

Share this post


Link to post
Share on other sites

ive tried we green gas and another brand carnt remember what it was called

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...