Jump to content
Kreso_cro

We m92 slide stucks?

Recommended Posts

Yes it isn't supposed to stick to that degree. Normally there is an extra click at that position but should not stick. Have you been lubricating the mechanism?

Share this post


Link to post
Share on other sites

If that is a new pistol bought in the UK then send or take it back to the shop.  If it's second hand, then try lubricating the rails the slide runs in with a "little" light oil.  Don't use silicon spray on metal to metal contact.

Share this post


Link to post
Share on other sites
On 17/10/2017 at 0:50 PM, Kreso_cro said:

You can see everything in the video..

I'm new to this sport and this is my first gun and I would like to know is this how it is supposed to be or is it something wrong 

 

Hello.. As RR01 says if it's a new pistol take or send it back to the shop you bought it from and get a refund or replacement, if it's still under warranty.. 

If it's not new or out of warranty, first things first,  take the slide off and inspect the blowback unit loading nozzle and the blowback unit housing, make sure nothing is loose or cracked causing the slide to stick, and check the blowback unit housing screw make sure it's not loose or damaged because if it's loose or damaged the hammer can get caught on it.. 

ATB Marc 

Share this post


Link to post
Share on other sites
On 10/20/2017 at 10:51 AM, Marc.RG1 said:

 

Hello.. As RR01 says if it's a new pistol take or send it back to the shop you bought it from and get a refund or replacement, if it's still under warranty.. 

If it's not new or out of warranty, first things first,  take the slide off and inspect the blowback unit loading nozzle and the blowback unit housing, make sure nothing is loose or cracked causing the slide to stick, and check the blowback unit housing screw make sure it's not loose or damaged because if it's loose or damaged the hammer can get caught on it.. 

ATB Marc 

Hi...I sent it back to the shop and they gave me replacement...new one works fine...sorry it took me this long to answer :)

Share this post


Link to post
Share on other sites
8 minutes ago, Kreso_cro said:

Hi...I sent it back to the shop and they gave me replacement...new one works fine...sorry it took me this long to answer :)

No problem at all mate, glad they sorted you out a new gun :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...