Jump to content
Sign in to follow this  
mimozine

old tokyo marui m4a1 carbine, intermittent problem

Recommended Posts

hi guys, dusted off my old tm m4a1 carbine, got it when it was first released so quite a few years old now. its got a grenade launcher and custom metal folding stock fitted.

 

anyway attached battery and fired it a few times in semi, worked fine then nothing. wiggled the battery wires about and it worked again. any idea what i should be looking for?

 

thx

 

andrew

Share this post


Link to post
Share on other sites

motor connections - hmmm - maybe but depends what/where wires were wiggled

 

very loose tamiya connections - or around fuse ?

 

loose wire inside box/switch - hmm doubt it

 

think any joins/connections should be checked first, could be a little corrosion on a loose connector/join is most likely

normally a thin spade connector at front handguard is a good place to start

might have pinched some wires in past so that could be next thing to look for

 

folding stock so presume ya battery is up front - check for loose corroded joins & pinched wires

also check motor connections in pistol grip - nothing too difficult just common sense and elimination

Share this post


Link to post
Share on other sites

My Brother in law just had a very similar problem. Turned out to be the selector plate, got a new one for £7 and job done.

 

Could be worth checking?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×