Jump to content
Sign in to follow this  
clumpyedge

TM 416D Bolt lock issue

Recommended Posts

Here is my problem I've got a problem with my TM 416D my friend took it apart ( as he did with his) to put in a new spring and a new gear set (his works fine).

 

When I finish a mag the bolt lock pops up to indicate the mag is finished but when I put a new mag in it doesn't seem to want to fire. The bolt lock when I put in a fresh mag (after finishing one) seems to just go back flush against the lower receiver rather than staying up allowing me to push it back in which should be the normal function....

 

I was advised by john at fire support it could be something to do with two pins inside the gear box that have been put in the wrong way round?

 

any idea's or help would be greatly appreciated

Share this post


Link to post
Share on other sites

sounds to me like it's sticking somewhere rather than badly assembled. I'd recommend opening it up and putting it back together, Richard Young from Eagle6 did a really good tutorial on the bolt catch assembly here:

 

 

 

 

you sir are a dude!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...