Jump to content
Sign in to follow this  
ikarma70

2 questions on m4 mags and kong power smart charger pls.

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

Hi all, out at the club yesterday my 2 m4 mags were playing up, my army armament mag stopped feeding even though it was wound up and my g&g hi cap occasionally didn't feed, am I need new mags or is there a quick fix for this?

 

Question 2........ I have a kong power balanced charger with no instructions on how long to leave batteries on charge for, my battery died after 20 minutes after a few hours charging, am I doing anything wrong(I am using the nimh setting)?

 

Atb

Andy

Share this post


Link to post
Share on other sites

Some guns don't like certain mags! Is it for your ICS M4? I use a G&G hicap in mine and it feeds fine. Maybe the spring has gone in the mag? You can dismantle it and check and lube the spring. Can you try/borrow a different mag to see if that shoots OK?

 

Not really much info on your battery or charger setting there. If it's a high capacity nimh being charged at a slow rate, it could take hours (8 or 9) depending on capacity and charging rate. What setting is it?

Share this post


Link to post
Share on other sites

My gun is a g&g cm16, the g&g mag works better than the army mag and it's the army mag which is not working, what lube would you suggest?

 

Battery setting is on nicad/nimh, after a while the charge light goes to lipo setting on its own, the batteries look ok but I guess only a multimeter can tell that?

Share this post


Link to post
Share on other sites

My guns have changed since I had the ics m4 but I can't seem to change my gun list.

Share this post


Link to post
Share on other sites

I found my CM16 hi cap magazine didn't feed all that well. It kind of worked but on full auto it couldn't keep up with the guns moderate 12 rps. I actually ended up buying a flash mag which didn't really miss a beat, it worked pretty well but still occasionally stopped feeding. Now I use midcaps, and despite having issues when they are completely full they feed flawlessly to the last BB.

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...