Jump to content
Sign in to follow this  
Bruiser

WE P08 Luger - HELP!!!

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) topic.

Recommended Posts

I have recently purchased a WE p08 luger 8'' (artillery luger). Despite reading the some what negative reviews I decided to go ahead and buy. But now when I fill it up with gas and load BB's, it doesn't seem to want to fire. Although, I repeatedly pull the trigger and it fires once every 5 pulls, sometimes 1 in every 2 and sometimes nothing at all, it's SO inconsistent! Has anyone had this sort of problem or a problem similar?

It's a really nice sidearm just wish I knew what the problem was

 

Thanks!

Matt

Share this post


Link to post
Share on other sites

Well I bought it around 3 weeks from Taiwan gun. And I seem to remember their policy being 'if there's nothing wrong with it in the 14 days' then you're unable to return? Plus I took it skirmishing the other day, minor signs of wear

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) topic.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...