Sign in to follow this  
Followers 0
tashidalek

we m1911 desert

12 posts in this topic

Bought a we m1911 desert few weeks ago (new) and its had "Gun Lube" on and it fires fine, the bit circled black seems to stick whens its in the back position (pic 2) and the latch which is arrowed is in the down position it still sticks and needs wobbling to release. this happens when i am pulling it back to make sure there are no bullets in and once or twice when firing. How do i fix it.

 

 

OMG cant you tell im a newbi.

post-2296-1299622433_thumb.png

post-2296-1299622555_thumb.png

Share this post


Link to post
Share on other sites

It's called the slide.

Share this post


Link to post
Share on other sites

do you have any idea how pistols work? Dont take offence to that question btw because that way its easier to work with and explain :)

Share this post


Link to post
Share on other sites

Either you are referring to the slide or the hammer, because they both "stick" back when the gun is empty :)

Share this post


Link to post
Share on other sites

ok i am slightly confused lol

Share this post


Link to post
Share on other sites

oh right yeah almost every pistol with a slide does that on an empty mag, nothing bad there

Share this post


Link to post
Share on other sites

oh i dont think so

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0