Jump to content

Archived

This topic is now archived and is closed to further replies.

SRGekko

Trouble with Star L85a2

Recommended Posts

My l85a2 is making what I can only describe as a strange noise when I try fire it and not firing any bbs.. I had it downgraded recently and think this could be the problem.. I had someone look at it briefly and he reckons it's an Allen type screw in the but plate that's come loose and let some of the internals come out of place.. I'm not sure of this is the case and even if it is it seems no Allen key that I can possibly find will fit this!! Anyone any similar problems?? Cheers

Share this post


Link to post
Share on other sites

I've not worked on a Star L85, but if it's set up similar to the G&G / ARMY versions then the motor is held in contact with the gears by being pushed forward by a plate in the back of the motor cage and the amount it is pushed forward is controlled by a small Allen headed grub screw in the back of the motor cage. Without taking out the gearbox you normally remove the two screws that hold the rubber butt plate in position, then access the grub screw through a hole in the metal end plate. It sounds like yours has wound itself out. The Allen key needed is about a 2-3mm one. Just wind it in until the motor starts to turn, but stop and back off a turn when it starts to make horrible noises. It should be turning the gearbox smoothly. Easiest way to do it is to split the receivers and take the top of the gearbox off, so that only the gears are turning without any strain.

Share this post


Link to post
Share on other sites

×
×
  • Create New...