Relayer2112

Borked GBB M4 Bolt

2 posts in this topic

This started out as a stock AGM M4 GBB - internally, it mostly still is - with the exception of the inner barrel. Externally, almost everything has been replaced with G&G gear (marketed as being compatible with AGM), and I had it put together by the guys at Land Warrior (so as to remove the possibility of me screwing up the internals in the lower receiver.)

 

So begins my woes - most likely due to my own stupidity. Was testing out the new build, making sure everything cycled correctly, and dry fired the weapon a few times. After about 3 cycles, there was a bang, and the bolt did not return, staying stuck in the rear position. In order to free the bolt, I had to remove the rear stock, and with a sharp tap, the bolt returned. I then was able to field strip the weapon, and upon removing the bolt, it was evident that a large chunk of metal from the inside of the bolt carrier had broken off completely.

A further test showed that the bolt would still become stuck at the rear and would not cycle properly. The bolt moves freely when the charging handle is pulled.

 

My question here is basically to see if anyone has any ideas what could have caused such force to be exerted on the bolt in such a way that it would break, and what parts I should replace to fix the fault.

 

Pictures of the bolt carrier showing the broken metal piece below:

post-3189-1310677904_thumb.jpg

post-3189-1310677931_thumb.jpg

Share this post


Link to post
Share on other sites

Hmm.

 

With my WE M16 related knowledge, I would say it looks like something wasn't seated correctly when you pulled the trigger.

 

It could be that some parts didn't fit right, they got caught on something or maybe something as simple as the charging handle not being locked in the forward position.

Normal internal pressures could more than likely do that, it's just that they weren't being used in the correct way.

 

Also, the bolt moving freely sounds like a problem with the buffer tube. It sounds a lot like there isn't even a buffer tube inside the stock.

I must have misunderstood what you meant by "moves freely".

 

I've never looked into the AGM GBB 'cos I heard it was the worst by far and I think I lack the knowledge to make it workable if I bought one... So I can't say for sure.

 

Aren't Landwarrior doing anything to help you out? Seems like it was most likely their fault.

Which is bad because I'm planning on buying from them at the end of the month! D=

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now