Sign in to follow this  
Followers 0
Petrellinkez

Urgent advice please guys!

3 posts in this topic

Quick question guys. I have a delta peak fast charger but when its charging it has gone from just a solid red light to a blinking red light. If anyone knows let me know urgently as i have like 7 batteries to charge for my mates for tomorrow.

Thanks

Petrelli

Share this post


Link to post
Share on other sites
Quick question guys. I have a delta peak fast charger but when its charging it has gone from just a solid red light to a blinking red light. If anyone knows let me know urgently as i have like 7 batteries to charge for my mates for tomorrow.

Thanks

Petrelli

Have you got the instruction manual?

Here.....

Share this post


Link to post
Share on other sites

Solid green - trickle charging

Solid red - fast charging

Flashing red - No charging occuring. Assuming the batt is actually plugged in, then it's usually an iffy connection at the charger terminals. Give ' em a wiggle or reconnect them. If it's not that then the second most frequent culprit is sh*tty tamiya connecters, and in third place comes damaged wire on the batt.

 

Of course what exact charger you have is anyones guess atm, and unless you've got the same one I have feel free to ignore my input totally. :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0