Jump to content
Sign in to follow this  
isaacgowling1721

Tm Hicapa Mags

Recommended Posts

So i own a TM Hicapa and i brought a bunch of TM Hicapa 5.1 mags. Since ive had them they've never feeded properly to the point where BBs get jammes before the reach the lip of the mags leading to dry firing and inconsistencies in the field, which as you can imagine is pretty frustrating. Ive tried cycling gas through them and lubing the mags with Silicone lube and ive tried stretching out feeding strings slightly nothing works

ive seen this be a fairly common issue with many mags but none of there solutions have worked for me so far so taking any advice i can 

Share this post


Link to post
Share on other sites

Highly irregular. What bbs you using? 

Share this post


Link to post
Share on other sites

 

3 hours ago, heroshark said:

Highly irregular. What bbs you using? 

nuropol .25g gram precise bbs

which i have used in many other guns before it has to be something to do with the mags coz ive used a mates WE 5.1 mags and they work perfectly

Share this post


Link to post
Share on other sites

If it's stopping at the start of the bottom of the lips sounds similar to a common clone mk23 mag issue. Check the transition between the feed to the lips. Sometimes the slightest step between can mess it up. Careful reshaping shaving with a sharp blade will fix it if it's that. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...