Jump to content
cptTHC

Brand new E&L AK feeding issues

Recommended Posts

So I done my research for a good solid AK and came to settle on an E&L from gunfire and although it's a beautiful bit of kit it just will not feed properly even with the mag it came with which fits snugly.

 

On semi auto it seems to fire every second shot (sometimes) and full auto it can jam up even when it doesn't fire every shot and the fps has been anywhere between 320-370 which is another issue on it's own 

 

Any suggestions for help would be ideal as I'm hoping to get out on the field this sunday 

Share this post


Link to post
Share on other sites

@cptTHC 👋

I have 2 E&L AK’s different models, both 2nd hand, both I believe are factory setting? 🤔

AKM

AKS-74U

I was fortunate to get my fair share of mags with them.

 

I found a few simple methods, to get them working: (My experience!) 🤔

1. Pull the trigger.

Sounds stupid, but being soft on the trigger it tends to not fire properly!

2. Double tap.

With both of mine they work after the 2 shot, but a few double taps, to make sure the motor is responding properly!

3. A burst of Full Auto

If the double tap, doesn’t work a good full auto burst should clear it, then should work for both settings!

4. Grip the mag.

Sometimes holding the mag, helps with the feeding system, also lets you know if your running low or out! 
5. Mag Springs and barrel maintenance.

Lubing the spring helps to work properly, good for maintenance and clean the barrel will help you shoot the target!

Hope this helps.... try them.... let me know!? 🔫😎👍

💷GAMBLE💷

 

 

Share this post


Link to post
Share on other sites
2 hours ago, cptTHC said:

On semi auto it seems to fire every second shot (sometimes) and full auto it can jam up even when it doesn't fire every shot and the fps has been anywhere between 320-370 which is another issue on it's own 

You might want to check the amount of hop you have on as it sounds like that might be causing the firing of every second shot and jamming on full auto to much hop can cause this.

 

You could also try switching mags if you have another.

Share this post


Link to post
Share on other sites
37 minutes ago, Samurai said:

Must use good BBs.

 

This, on anything but geoffs both my ak's dislike feeding, give them the good stuff and you get every round every time.

Share this post


Link to post
Share on other sites
On 14/03/2020 at 09:01, Samurai said:

Must use good BBs.

That was a good part of the issue thanks! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...