Jump to content
Pixilus

WE G17 Slide Sticking

Recommended Posts

I've had myself a WE G17 for a while now and ever since I got it it's had an issue where the slide will stick halfway back if pulled there, or after firing sometimes it will get stuck in that position as well.

Now this is a big ass pain, especially when I'm in the middle of a game.

What I wanted to know was is this a problem with all WE glocks or specifically with the stock custom one I bought (https://www.milspecsolutions.co.uk/gas-blowback-pistols/we-pistols/WE-G-FORCE-G17-Custom-Pistol-Black-Slide-Gold-Barrel.html) or just a one off thing with my particular glock, and is where a way to fix it or mod it to make the slide smoother.

I've had a look at the internals to try and figure out what the slide is resisting against but can't figure it out.

 

(Video

shows the slide stick problem better than I can explain it).

Share this post


Link to post
Share on other sites

Haven’t watched the vid, but two things will fix it. Clean it thoroughly, and lubricate t correctly.

Then replace the standard hammer bearing with a roller bearing 

Share this post


Link to post
Share on other sites
55 minutes ago, rocketdogbert said:

Haven’t watched the vid, but two things will fix it. Clean it thoroughly, and lubricate t correctly.

Then replace the standard hammer bearing with a roller bearing 

Like this? (https://www.rainbow8.com/products/gunsmodify-bearing-rotor-set-for-tm-g17-hammer-gm-zero-housing-set-hammer?_pos=2&_sid=6036a3b31&_ss=r)  Will this TM part work in this WE one? Since I know we is tm copied.

Share this post


Link to post
Share on other sites

Yes, exactly that, but I’d try and get one from the UK or you’ll be waiting months lol

Share this post


Link to post
Share on other sites

First course of action should be clean and lube. Then look for where the slide isn't running smoothly and perhaps carefully file. I've experienced this before, even with Marui Glocks but they break in after a decent amount of usage. You could speed that up by removing the magazine and racking repeatedly  until it improves.

Share this post


Link to post
Share on other sites

When I first got my WE G23, the after test firing it, I took the thing apart.  I found that the internals were very dry, so after some serious cleaning and lube, put the thing back together and I have not had a problem with it since.  Racking the slide to ensure that all parts are lubed also helps.

Share this post


Link to post
Share on other sites
18 hours ago, Damion said:

When I first got my WE G23, the after test firing it, I took the thing apart.  I found that the internals were very dry, so after some serious cleaning and lube, put the thing back together and I have not had a problem with it since.  Racking the slide to ensure that all parts are lubed also helps.

I've cleaned and lubed it multiple times since I've had it, and it's always done it. When Corona dies down I'll get some new parts for it and hope it fixes it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...