Jump to content
Sign in to follow this  
Chatter

My Slide on my 1911 won't go far enough back to go back together

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) topic.

Recommended Posts

Hi all. New airsofter here. I bought a King Arms Predator Tactical 1911. I took it apart to clean it today and after assembling it again the slide just won't lock back far enough to allow me to put the pin to move the parts forward again. 

 

I don't know whats wrong or how to fix it and am really worried I've bought my first gun and broken it on the first day. 

DSC_0084.JPG

Share this post


Link to post
Share on other sites

Just a guess but looks like the grip safety doesn't let the hammer move out of the way of the slide. Grip it.

Share this post


Link to post
Share on other sites

Silly question, but have you taken the magazine out?

 

I can’t see from the picture you posted.

Share this post


Link to post
Share on other sites

are the recoil spring and guide correctly positioned ? pic of the underside of the slide might help

Share this post


Link to post
Share on other sites

Have you checked for woodland creatures which may have sought shelter from the storm?

Share this post


Link to post
Share on other sites
17 hours ago, Cyberlawyer said:

Silly question, but have you taken the magazine out?

 

I can’t see from the picture you posted.

Please tell me you've removed the magazine before field stripping 😮

 

1, is the barrel bushing fitted? Bushings are the last thing that goes back in a 1911 during reassembly and can cause reassembly issues. 

 

2, does the slide come to a complete stop in the position shown? It could be (as suggested above) your recoil spring and plug are misaligned. Some 1911 patterns rely on a precarious balancing act in this part of reassembly, which can be tricky. 

 

3, check your nozzle isn't stuck in the forward position. I had a M45a1 that did this every time I field stripped it. 

 

17 hours ago, Samurai said:

Just a guess but looks like the grip safety doesn't let the hammer move out of the way of the slide. Grip it.

If this is happening, this doesn't sound good. I have numerous 1911s and none of them have this issue. 

 

 

Hopefully this helps, if not I'd suggest taking the gun back to the store or searching out a decent tech. 

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) topic.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...