Jump to content
BibbsOnTour

ASG CZ P-09 Slide Inconsistently Cocking

Recommended Posts

So, I was trying to chrono my p09 earlier and noticed that 1) it was shooting very low power compared to when I used it last weekend (brand new) and 2) when empty the slide would not lock back.

 

I figured perhaps this is because after me using it I had not cleaned the barrel properly (causing low power) nor lubed it properly (causing slide to not come back enough to lock as I had already considered not enough gas to kick it back enough so filled the mag to near full and it still wouldn't work)

 

Anyway, took it apart and gave it full clean in the barrel and wipe down of all the lube and re-lubed and then went to put it back together and now the slide will not allow me to cock it back properly.

 

Bit strange because:

  • If the locking pin is out and the pistol is held at the normal angle as if I were looking down the sights I can cock it fully
  • If the pin is out but I hold it upright as if I were to look down it through the magwell and out the bottom it won't cock back at all (moves about a few mm and then will not budge unless I really yank it and then the whole upper comes back with it (hop unit, barrel etc.) so I can't look down the magwell as nothing opens.
  • If the locking pin is in I can't get anything to move at all no matter how much I'm forcing it (within reason as don't want to break my new pistol(unless I have already 😥)) it is also very hard to take apart once assembled with locking pin in

 

I have tried to look at videos of people taking it apart to see if there's anything obvious I haven't done but as far as I'm aware I did it exactly how I did it last time but now it's doing this ☹️

 

Pics of inside the lower and upper below - not sure if they will be of any help though as at this point I'm not sure if there's something specific I should be looking for.

 

Let me know if anyone want's a picture of any specific part that may be of use when trying to diagnose my f*kc up 

 

 

1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

Share this post


Link to post
Share on other sites

Hi, I saw you figured out your own problem but I stumbled upon this thread with a similar issue. My cz-po9 has been unable to rack for a while. I was wondering what you did to fix the problem exactly? If I have the takedown pin in the slide moves back about a millimeter but then gets stuck. If I take out the pin regardless of how I hold it it will sometimes go back normally, but other times it will get stuck with the hopup chamber and barrel. Not as often but also the slide will go all the way back but te hopup chamber will appear to fall towards the magwell. I am hoping you might have some expertise as to what is going on?

Share this post


Link to post
Share on other sites
12 hours ago, Iansr36 said:

I am hoping you might have some expertise as to what is going on?

From what I recall I just took it down and reassembled a few times until it worked properly. Not exactly sure what I did to cause it to not work but assume something just wasn't sitting correctly as after the 2nd or 3rd attempt it worked as it should and I haven't had the issue since.

 

Hope this helps a bit!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...