Jump to content
detectdtc

WE G18C Slide Sticking, Please Help!

Recommended Posts

Hey guys, I really really need help on this issue.

 

It's been an issue for so long and I haven't got around to fixing it, so pretty much my WE G18C seems to for some reason have its slide sticking, however the slide is sticking before it actually hits the slide lock and sticks behind it, as shown in the image the red arrow is pointing toward the piece that it's sticking on, and this piece is supposed to go down, i'm not sure what to do and how to fix it, so is anyone able to help? the issue was caused randomly when I took it apart one day and put it back together, could anyone help me with a solution to this issue? Thank you so much!

 

(EDIT: I believe the part is called the Valve Knocker Reset if that's any help!)

1.PNG

3.PNG

Share this post


Link to post
Share on other sites

Slide is only meant to go that far forward when you remove it, if it started when you took it apart, you either broke something or put my it together wrong lol

Where are you based?

Share this post


Link to post
Share on other sites

Potentially but surely there's something in the hammer that's causing it not to reset? it still moves and stuff, would it be possibly to file it down or something?

 

I'm based in the UK, why? 

Share this post


Link to post
Share on other sites

Because rocketdogbert is a fountain of knowledge for glocks and is trying to help you.... just a wild guess.

Share this post


Link to post
Share on other sites
2 hours ago, Immortal said:

Because rocketdogbert is a fountain of knowledge for glocks and is trying to help you.... just a wild guess.

 

Lol yup

 

Back to your problem, are you saying the slide won’t go on at all and the gun doesn’t fire? Or something else? First picture appears to show the slide going past the pin, the second one in front of it.

 

Video is always helpful, as at the moment I’m not sure I understand your issue, sorry

 

And if your near me (south east Essex) I can take a look at it

Share this post


Link to post
Share on other sites
1 hour ago, rocketdogbert said:

 

Lol yup

 

Back to your problem, are you saying the slide won’t go on at all and the gun doesn’t fire? Or something else? First picture appears to show the slide going past the pin, the second one in front of it.

 

Video is always helpful, as at the moment I’m not sure I understand your issue, sorry

 

And if your near me (south east Essex) I can take a look at it

 

Sorry if that came off rude, but what I mean is the slide goes on and all, but when you cock it back it locks on the Valve Knocker instead of the Slide Lock, so if I was to push up the slide lock whilst it was on the Valve Knocker then it doesn't do anything and doesn't bring the slide back, i'm just generally very confused :( 

Share this post


Link to post
Share on other sites

It could be a number of things, I don’t suppose you are near to me?

 

If not, take out the hammer assembly, make sure all the springs are in place and not missing or bent

 

 

 

Share this post


Link to post
Share on other sites
12 hours ago, rocketdogbert said:

It could be a number of things, I don’t suppose you are near to me?

 

If not, take out the hammer assembly, make sure all the springs are in place and not missing or bent

 

I'm in the Dorset area and Warminster Airsoft is my local site so i'm relatively far unfortunately, I really appreciate the offer for you to have a look at it though, I'll check that video out and see if I can find a solution, thank you so much man. 

 

 

Share this post


Link to post
Share on other sites

Good luck, shout if you need anything👍🏻

Share this post


Link to post
Share on other sites

Okay so I had a little play, and just removed the Valve Knocker Reset just to see what would happen, I've reassembled and the gun is fine and isn't catching, however - what's the downside to literally not having a Valve Knocker Reset?

Share this post


Link to post
Share on other sites

Have you fired it? My experience is firing on Auto doesn’t matter, but you can’t  fire single shot

Share this post


Link to post
Share on other sites

I'll have to fire it at some point tomorrow and let you know, honestly I don't mind just having Auto, i'm just happy that it will shoot, the site I go to has a technician who is there on some days and he said he'd be happy to have a look at it, but i'll try tomorrow and give you a shout if there's anything wrong, I really do appreciate the help bro it means a hell of a lot ❤️ 

 

I'll keep you posted! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×