Jump to content
Lokai

Lipo charging help

Recommended Posts

Evening all, looking for some noob assistance please.

 

So, got my first lipo battery this week along with what I thought was a decent charger to go with it. 

 

First problem, the charger didn't come with the right cable. So off to Amazon I went and bought a multi connector banana cable.

 

Decided to get it charged today so I could play with my new rifle.

 

When connecting the battery to the cable red was going to black , I thought it was supposed to be red to red, black to black. As soon as I connected the charger flashed up reverse polarity so I quickly unplugged and haven't dared try again since!!!!! 

 

A few pics below to show what I mean. Any advice? Dying to try new gun :D but don't want to burn the house down (may have read too many horror stories about lipo's blowing up etc)!!

 

thanks for the help.

 

IMG_20180708_200044.jpg

IMG_20180708_195445.jpg

IMG_20180708_195421.jpg

IMG_20180708_195407.jpg

Share this post


Link to post
Share on other sites

Does your charger have these ports? If so, charge through the smaller of the two. As for your adaptor, you'll have to swap that Tamiya connector around as it should be r/r b/b.

Share this post


Link to post
Share on other sites
8 minutes ago, Duff said:

Does your charger have these ports? If so, charge through the smaller of the two. As for your adaptor, you'll have to swap that Tamiya connector around as it should be r/r b/b.

 

Cheers Duff, I was thinking that would be the case.

 

These are the ports -

IMG_20180708_202055.jpg

Share this post


Link to post
Share on other sites

You need to charge it on the balance lead, NOT the Tamiya connector 

Share this post


Link to post
Share on other sites
5 minutes ago, E21A said:

You need to charge it on the balance lead, NOT the Tamiya connector 

Thanks, I did initially try this but I just get a "connect error check main port" message flashing up.

Share this post


Link to post
Share on other sites

Swap the banana style leads over that goes into the charger and plug in the white balance lead connector... simples

Share this post


Link to post
Share on other sites
1 hour ago, Chris_B said:

Swap the banana style leads over that goes into the charger and plug in the white balance lead connector... simples

 

Why didn't i think of that!!! Lipo is now balance charging as we speak!!! Thanks for the help.

Share this post


Link to post
Share on other sites
10 hours ago, E21A said:

You need to charge it on the balance lead, NOT the Tamiya connector 

 

Couldn't for the life of remember what it was bloody called. 

Share this post


Link to post
Share on other sites

Amazon leads are often ar$e about face polarity cheapo china converters

 

Part of reason is coz on small tamiya RED is Round connector & BLACK is Square

BUT

on Large taimya (ye olde guns and RC stuff), BLACK is Round & RED is Square

 

so the two tamiya type connectors have different polarity/pinouts

then add in cheapo fleabay/Amazon/China plugs and you end up with a 50/50 lottery

very often the fleabay ones are wrong polarity for airsoft peew peew

 

grab a pin/needle, push it down the unplugged converter, releasing the connectors

then swap them over to correct polarity - simples - 5 min job if that

 

if you had bought the converter from a reputable place like component shop it would have been correct

 

once you get the hang of soldering you will probably go deans on most guns

then make up your own leads/converters if need be from old bits of wiring loom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×