Jump to content
Airsoft Forums UK
Sticks

WE M92 Stuck in Full-Auto

Recommended Posts

So my new WE M9 seemed like a wonderful pistol. Tried it a few times in the garden and then took it out for a match. Worked well for all of the day up until it got stuck firing on full auto. No matter where the fire selector is it fires on full. I tried a different mag, a fresh mag, unloading it fully and a new mag. Even tried it again the day after (as the day I was using it on was particularly hot).

 

Now I'm at a bit of a loss of what could be the issue. I've stripped it down to an extent, but I cant work out how to remove the fire selector to even look a the slide parts.

 

Any one have any info on what might be causing this?

Share this post


Link to post
Share on other sites

There is a video on YouTube on how to solve this, it is the trigger sear. 

 

Basically you just just file a little away from the sear and it solves the issue.

Share this post


Link to post
Share on other sites

Could you link me to the video?

 

Also after taking apart the selector theres a little screw that seems to pull up a small lever on the slide, which seems to be sheered? could it be that too?

Share this post


Link to post
Share on other sites

Mine did exactly the same, it's this part in the photo. Try and move the selector around and see if the bar/ plunger moves when the slide is dismantled & upside down.

IMG_20180706_191916.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×