Jump to content
Airsoft Forums UK
John51

Battery Problem!

Recommended Posts

So yesterday my MP-40 AGM came to my home and I really wanted to try it out.So after charging the battery for 20 minutes,I put it into the gun and after pressing the trigger I heard a really faint sound.And that was it.After that point the battery just won't charge.I had it charging for 12 Hrs(as the manual says)and it wasn't hot at all!The charger on the other hand was hot as h*ll!I know I made a stupid mistake on my part but there must be a fix or something...

Share this post


Link to post
Share on other sites

Buy a new battery and open a claim on the current one with the supplier stating it's faulty. If it gets sorted down the road you'll end up with a spare battery with any luck.

 

And when the battery arrives charge it properly.

Share this post


Link to post
Share on other sites

I just ordered a new battery.It's manufacturer is Hong Kong.I think it's gonna be better than the one I that have .

Share this post


Link to post
Share on other sites

Is this a Nihm battery and a dumb charger?  I'd bin (well, recycle) them, and get yourself a lipo charger and a couple of appropriately sized 7.4v lipos from HobbyKing: https://hobbyking.com/en_us/batteries/airsoft.html?config=52

 

Ideally you'd want to rewire the gun to Deans (what HobbyKing call 'T-connector') but let's leave that for the intermediate class.  For now, you can stick to mini-Tamiya and think about rewiring everything later.

Share this post


Link to post
Share on other sites

Eff me.  We've seen chargers catch fire as well.  That's one for trading standards, if you're minded to put the time in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×