Jump to content
Sign in to follow this  

Comms problems

Recommended Posts

Hi, I've got a pair of Motorola T80 Extremes and a Z-Tactical Peltor clone headset, I've now tried 3 different Z-Tac PTT units and none of them work.


They can receive transmissions but the PTT unit doesn't seem to work (it does not transmit when the button is pressed).


Has anyone had any experience with motorola radios and the Z-Tac PTT units or had this problem and solved it?



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...