Jump to content
Sign in to follow this  
Shaddow

Classic Army M14 Low Power issue!

Recommended Posts

Hi,

So I received my CA M14 Match that I recently bought from a forum member. Rifle looks good as new with little to no marks on it, so don't expect it has been used much in its previous life.

Getting it ready, I fitted some Deans connectors and plugged my battery in to shoot a few rounds and make sure it all works as it should.

 

A few rounds managed the amazing distance of around 5m with a very downward curve. (Not hop, just a very low amount of power). Most of the rounds however did manage the full distance of my garden, but not at the speed I would have expected. (Sure they seemed slower compared to my Honey Badger.)

 

Plan is to do a complete strip down, clean and re-grease to hopefully sort out whatever is causing the lack in power.

 

Has anyone experience anything similar? Something specific I can look at to hopefully resolve my issue?

 

Long term plan is to convert to a DMR, so will also need to look into upgrading inner barrel, spring, gears etc..

 

Thanks

Share this post


Link to post
Share on other sites

Sounds like an airseal issue. If you're going to dmr it then you'll be wanting a new hop rubber anyway so I wouldn't worry about it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...