Jump to content
Sign in to follow this  
asbo1991

ICS CXP HOG shooting full auto on semi

Recommended Posts

Hi all,

 

Not long had this skirmished it twice but I have noticed that it shooting full auto ever now and again when set on semi.

 

I had search previously and thought it was the double fire situation due to the spring realises system when you put the gun on safe and it not double shoting.

 

I thought it could be a battery but I have tried a 9.6v and 8.4v NiMH this didn't solve the issue, it happens on these as well as both my 7.4v LiPo's

 

Anyone ever come across this situation before, know what the cause is and how I potentially fix this?

 

Cheers,

Tony

 

 

Share this post


Link to post
Share on other sites

Disable the spring release.

 

It will do it when you go from semi or full auto to safe when the last shot has over cycled and the spring was pre-cocked after the last shot.

When you engage semi again the first trigger pull will be full auto. Only way to stop it is to either fit an ab mosfet or disable the spring release.

Share this post


Link to post
Share on other sites

Thanks trigger

 

I will look at fitting a MOSFET but how do you disable the spring release?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...