Jump to content
Sign in to follow this  
sniperslucky

Trigger problem

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

Hi All,

 

As above, when the battery is disconnected on my M4 the trigger works fine in semi, full auto and safety, when the battery is connected the trigger does not return on semi and i need to push the trigger forward to take another shot but when on full auto the trigger returns to the normal position ???????????.

 

I have stripped the gearbox down and rebuilt it and the trigger operates the same as before.

 

Any ideas

Share this post


Link to post
Share on other sites

The actual trigger's spring is broken/missing - that is what it sounds like

think many of us have tried to close a box without them bastid trigger or AR latch springs....

yup you do need them in there

 

Reason why auto works - the switch trolley spring up top is pushing back the trolley & trigger together

 

On Semi - the trolley is lifted of the trigger/sear and flies backwards...

if the trigger's spring is not working/broke/missing then the trigger just sits there and you have to push trigger backwards to re-latch onto trolley again

 

Well that is the general principal of it all

 

Have had a gun fire full auto on semi and remain firing full auto due to pinching contacts too tightly (not wise to have them too tight)

But sounds like your issue is down to trigger spring problem I reckon unless I've misread your description

Share this post


Link to post
Share on other sites

Thanks Sitting Duck , i'll take it apart again and have a closer look. :)

Share this post


Link to post
Share on other sites

You where spot on Sitting Duck, spring was there just snapped

Share this post


Link to post
Share on other sites

Getting in touch with pete / ak2m4 on here or FaceBook to confirm the ZCI spring set includes the trigger spring:

 

http://www.ak2m4.co.uk/internal-parts/misc-internal-parts/zci-gearbox-spring-set-v2

 

Yeah I know it says it is in there but just double check won't hurt

as often even SHS spring sets don't include the trigger spring

 

So worth an extra quid - £4 over a £3 set with no trigger spring as you need a new one

Share this post


Link to post
Share on other sites

Thanks Sitting Duck, that was my next Q? as i could only find sets including triggers. Looks like the spring top left on link is the one i need.

Share this post


Link to post
Share on other sites

Getting in touch with pete / ak2m4 on here or FaceBook to confirm the ZCI spring set includes the trigger spring:

 

http://www.ak2m4.co.uk/internal-parts/misc-internal-parts/zci-gearbox-spring-set-v2

 

Yeah I know it says it is in there but just double check won't hurt

as often even SHS spring sets don't include the trigger spring

 

So worth an extra quid - £4 over a £3 set with no trigger spring as you need a new one

 

All good sitting Duck comes with spring spoke to Pete who confirmed order place awaiting goods :) .

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...