Jump to content
B.S

KJW G23 Dropping BBs after each Shot.

Recommended Posts

So, I'm having another issue, Likely yet another Symptom of being new to Airsoft.

My KJW G23 seems to be having issues, It works fine in Dry Firing (Which Is all I tend to do, since I don't see the need for Rounds being fired outside of a game.) But as soon as I fire off a Clip, It Fires a shot, Then drops the next one out the barrel. Every shot. it has the effect of making it a 10 round clip, not a 20. (Although, you can only fit 19 for some reason) I had a similar issue before but it was only occasional shots, I think it still would be, But I'm firing it at a downwards angle. Quite frankly I'm clueless as to why. It's probably a Simple issue, or just something with this Make of gun, or User Error, Maintenance etc. But, If anyone already knows how to fix it, I'd be grateful.

 

My Theory is it's a problem with the Feeding, The BB seems to sit fine in the chamber (I chambered one with no gas in the mag, and It didn't roll out the end or back after I removed the mag.) So It must be something to do with what happens to the BBs as they are loaded after each shot. But this is where I get lost, I've no idea how this is causing them to roll out the barrel, Or how to fix it. Could it be the Loading nozzle is Pushing them out the Barrel? Perhaps to far to be chambered correctly? Although this wouldn't explain why every other shot fires. any ideas would be welcome.

 

EDIT:

I did another test, And it turns out I was wrong, Every shot I fire falls out. After maybe 2 or 3 shots, they start just rolling out after the Gas is released.

Share this post


Link to post
Share on other sites

l'm guessing the hop rubber just isn't holding the shots in the breach.

 

Try applying more hop to see if it starts to hold them in; if it does then and your shots aren't being sent high then l'd just leave it at that.

 

But if your shots are being sent high then try refitting the hop rubber - lt's probably not sat quite right.

 

 

Failing that solving the issue though, l'm not sure what else it could be without having it in front of me and inspecting it more thoroughly.

Share this post


Link to post
Share on other sites

l'm guessing the hop rubber just isn't holding the shots in the breach.

 

Try applying more hop to see if it starts to hold them in; if it does then and your shots aren't being sent high then l'd just leave it at that.

 

But if your shots are being sent high then try refitting the hop rubber - lt's probably not sat quite right.

 

 

Failing that solving the issue though, l'm not sure what else it could be without having it in front of me and inspecting it more thoroughly.

 

Thanks, I'll fiddle around with the Hop and See if that Changes anything. I appreciate I'm probably a bit of a Pest with all my Problems XD

Share this post


Link to post
Share on other sites

Seems to have helped, it didn't have the problem as often but It's not completely gone. Still does it on occasion, but it can fire off a whole clip without a problem now. I'm not sure how I'd go about refitting the hop rubber though? There doesn't appear to be any way of getting inside the Hop unit.

Share this post


Link to post
Share on other sites

The hop unit is usually held together in two halves by a small screw. You will probably need a very small / jewellery screwdriver to undo it. Once open you can lift out the barrel and change the hop rubber.

Share this post


Link to post
Share on other sites

The hop unit is usually held together in two halves by a small screw. You will probably need a very small / jewellery screwdriver to undo it. Once open you can lift out the barrel and change the hop rubber.

Thanks, I'll take a look.

 

EDIT:

I took apart the hop, After putting it back together it shot terribly, not only dropping BBs, but shooting low too, Turns out I'd hit the hop wheel. After this, I figured out how the Hop actually works, So I realized I'd Turned the wheel the wrong way! XD the rubber was just too tight, Like I originally thought, it was just my noobyness that caused the issue, But at least now I know How it all works, For next time. Thanks for all the advice!

Share this post


Link to post
Share on other sites

Here ya go :)

 

Magazine-Clip-Featured.jpg

Magazine-vs-Clip-Firewoodhoardersclub.jp

 

Don't say it wrong on camera or someone will f*cking crucify you.

 

XD Thanks! I'll bear that in mind.

Good to know Terminology.

Share this post


Link to post
Share on other sites

also worth opening youtube and searching for assembly/disassembly vids as they help massively when doing things for the first time.

Share this post


Link to post
Share on other sites

also worth opening youtube and searching for assembly/disassembly vids as they help massively when doing things for the first time.

 

Yeah, I always forget I can just look stuff up XD

Like I said, This was more me not knowing how Hop Up works than anything else. If I know exactly how everything works, I can figure out how to fix it. Airsoft is just a matter of experience.

Share this post


Link to post
Share on other sites

no idea if this vid is any good:

 

 

Thanks, But I mostly know how to Dissemble it now :) I also knew how to adjust the hop, I just didn't know how it worked so I didn't understand how it could cause a problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×