Jump to content
Sign in to follow this  
ronin677

Problems with feeding in my CYMA 701 (VSR Clone)

Recommended Posts

Hi all,


So I have just put an AirsoftPro twin lever hop unit in my CYMA 701b rifle. At the same time I upgraded the barrel to a X Fire 6.08 precision barrel. Put it all together and tuned the hop up unit, till it was firing like a dream. The tuning was done by manually feeding the bb's into the hop up one at a time for convenience (the twin arm hop unit has to be adjusted without the magazine on by allen key). So happy days so far.


I then found that when I put the magazine in, the magazine empties completely in one go as soon as the bolt is pulled back. All the bb's empty backwards into the body of the rifle. I think the problem is the notch in the hop unit as circled in my photo. Any ideas how to fix this problem?


20160305_154943.jpg

Share this post


Link to post
Share on other sites

On the hop, unit there should be two black screws on the outside which push in the derlin spacers, I had the same issue or at least something similar and it was resolved by loosening the screws or tightening.

 

That nub bit you've circled and shouldn't be touched, worst case scenario, grab a different VSR ho block, some of the clone ones are a bit off spec.

Share this post


Link to post
Share on other sites

Turns out it was the rubbish stock magazines that were the issue. Worked fine until I upgraded the hop unit. Tried a couple of different ones this afternoon and it seems to have fixed the problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×