Jump to content
Sign in to follow this  
Foon

Tokyo Marui Mp7

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Recommended Posts

My mp7 uses a full magazine of gas on one or two shots. The o-rings on the mags are fine as they can hold gas for weeks easily so I'm assuming something in the gun is wasting all the gas at once some how. I have no idea and any suggestions would be appreciated :)

 

I use green gas and the gun is stock as i havent opened it up to tamper with any of the internals as im new to gbb and have no idea what i would be looking at.

Share this post


Link to post
Share on other sites

Disassemble, clean, lube and reassemble. Sounds like the hammer isn't resetting when you shoot so it's either a displaced spring, dirt trapping it or broken altogether. There are loads of disassembly guides online so take a couple of hours and have a look at it for yourself - identifying the broken part should be simple once you compare it to that from a video.

Other than that you could send it off, but either way getting to the hammer in any of the MP7s requires significant disassembly. It's not hard if you're patient, but will be a little frustrating the first time.

Share this post


Link to post
Share on other sites
This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) thread.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...