Jump to content
BrutalLemon

Gas Tanaka Sic 93 (lookalike M93R) FIRING ON IT'S OWN!?!

Recommended Posts

Hi guys,

 

This gun is firing off a full magazine without me even pulling the trigger. It is as soon as I put the magazine into the gun it just goes off full auto. Pretty dangerous!

 

https://youtu.be/YXQFKTpfFC8

I'm not sure if that link will work but it is me shaking the magazine. It makes a clinking sort of sound like something is loose.

 

 

I thought I would ask here first before going to my local gun shop after some great advice from these forums regarding another gun I was having problems with.

 

Hopefully someone knows what is going on!

 

Thanks,

 

Chris

post-5636-0-81927100-1444665637_thumb.jpg

Share this post


Link to post
Share on other sites

Sounds like you have a bad case of a trigger happy poultergeist...

 

In all seriousness. I think it may be either your outlet valve on the mag, or your firing pin is jammed forwards. Can you try another mag? If you push an empty mag into the gun, is there any resistance just before it locks? (like the outlet valve getting caught on the firing pin)

Share this post


Link to post
Share on other sites

Sorry for my late reply guys. I have taken a few photos of the different sides of the magazine.

 

When I push an empty mag in there is no resistance to speak of and clicks nicely into place.

 

Annoyingly, my friend took my bottle of gas home with him so I gotta wait to make a video showing you guys exactly what happens! <_<

 

It must have something to do with the valve as it starts firing as soon as the magazine clicks into place. Really annoying as this is my best sidearm!

 

post-5636-0-33998600-1445874269_thumb.jpg

 

post-5636-0-67466100-1445874301_thumb.jpg

 

post-5636-0-90623800-1445874332_thumb.jpg

 

post-5636-0-30566300-1445874362_thumb.jpg

 

 

Share this post


Link to post
Share on other sites

Try this

 

With the magazine removed, press and release the trigger

With your longest finger, reach inside the mag well and feel for the firing pin, it should be positioned right behind the valve when the mag is in

Whilst feeling the pin, pull the slide back

 

Does the pin move backwards out of the mag well?

How far back does it move?

Share this post


Link to post
Share on other sites

Unfortunately my sausage fingers won't reach the pin but I had a good look down the mag well with a light multiple times and i'm pretty certain the firing pin is moving backwards out of the mag well and stays flush with the side when the slide is back.

 

I took some photos with the flash down the mag well and I noticed something that doesn't look right to my noob eyes. The gold "thing" in the photo almost looks sheared and torn? Is that normal?

 

post-5636-0-03169100-1445883718_thumb.jpg

 

post-5636-0-45232700-1445883732_thumb.jpg

 

 

Share this post


Link to post
Share on other sites

I'm not familiar with the pistol, so I don't know what the gold piece is I'm afraid

 

Did the pin stay back when you let the slide forward again? If so, and pressing the trigger pushes it forwards instantly, then your trigger is working somewhat well. It could be getting fouled by something but if the pin behaves itself I'd start looking at the magazine and the mag well

Share this post


Link to post
Share on other sites

Thanks for your help guy, I think my best bet is to get another magazine. Then I can at least suss out whether the problem is within the gun or not. If not, I have a second magazine, not a bad thing.

 

If anyone else knows whether or not the gold part in the above photos looks busted please let me know.

 

Thanks for all your replies people :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×