Jump to content
Sign in to follow this  
Ryry

Jg g3 sas fires two - shots on semi

Recommended Posts

Hi guys not had this problem before but my g3 seems to fire 2-3 shots when on semi auto ,it also gets stuck wen on fully auto and keeps firing when trigger isnt being pulled any suggestions on what the issue could be ?

Share this post


Link to post
Share on other sites

are you using a lipo,

if you are you may be giving the motor too much power which causes it to cycle twice on semi.

but because youre getting stuck on full auto, it maybe dodgy trigger contacts

Share this post


Link to post
Share on other sites

oops soz misread - thought it was feed issue dooohhh

 

yup trigger switch area, carbon build up maybe and trigger contacts getting stuck

(could be cut off but to keep firing on auto means the plunger is remaining closed)

 

it should stop firing on auto when trigger released

so it is getting wedged on the contacts for some reason and spring not pulling it back

(spring must be still there but maybe a bit weak or the contacts are pinching and grabbing the switch too tightly ?)

 

new switch may be needed, the old one might be ok to clean up but wise to have a new one in case it is shot to crap

Share this post


Link to post
Share on other sites

Just been using standard 8.4v nimh , i did think it could of been trigger as you say and it is a well used gun .

Cheers guys

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×