Jump to content
Sign in to follow this  
NiallAckroyd

It appears my sniper is buggered. Any ideas?

Recommended Posts

Hello,

 

So basically I put an m150 in my l96, and it was firing at around 585, so i got it cut, it fired ok between 491 and 510, but then the cylinder started to make a farting noise, so naturally I took my cylinder apart, moved the parts around and then put it back together, when it was back together I pulled the cylinder back, and now its stuck back, it wont go forward, and now i don't know what to do. Any ideas?

 

Thanks,

Niall

Share this post


Link to post
Share on other sites

yes, I put in a type 96 EZ trigger

Share this post


Link to post
Share on other sites

no, it just went in, i assume thats where the farting noise comes from, i just don't know why the cylinder won't go back forward

Share this post


Link to post
Share on other sites

it *could* be that your spring may have jumped out of the piston fouling it up. if this is the case, the farting noise may have been the sear catching on the spring.

 

if it wont go forward at all you may have to pull the spring guide stopper, but please do this carefully as the cylinder may shoot forward.

 

from what little i know about clipping sniper springs, most of what i have read has been on M170'ish springs. But if i am honest i am not that knowledgeable on sniper spring clipping etc.

Share this post


Link to post
Share on other sites

i see, if im honest the spring may just be too short, and i not too sure, but the spring guide stopper may be stuck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×