Jump to content
Sign in to follow this  
skeeter

G & G CM16 carbine selector problem

Recommended Posts

After reading this forum I took the plunge and bought a CM16 carbine (clear plastic body I have no UKARA registration) from Pro Airsoft supplies. After unboxing all appeared well (couple of minor issues-nothing to worry about) selector switch seemed stiff but, its a new gun, right?

 

Got a battery for it and dry fired it, all OK. The battery had to be replaced because they sent the wrong size. Fitted the second (correct) battery fully charged, selector switched from safe to semi to auto, dry fired OK on each. Back to semi and there it remains, stuck. Fast. Won't go back to safe or auto. Fires BB's ok on semi. (in fact as a newbie to Airsoft guns, I thought it was fantastic!)

 

Anyone have any advice/work arounds before I have to go back to Pro Airsoft?

 

Many thanks for anything you can suggest,

 

Skeeter

Share this post


Link to post
Share on other sites

BTW the "wrong size" battery was literally just that it was too long, nowt to do with voltage etc.

Share this post


Link to post
Share on other sites

sounds like your selector plate is stuck, it sits of the outside of the gearbox and the copper plate pushes on pronges to activate single and full auto only thing I can think of is the selector plate.

Share this post


Link to post
Share on other sites

I have had mine like a day, put around 2000bbs through it. Idk what your problem is, but when I got my gun everything was quite stiff. At one point I couldn't pull the trigger. I had to wait and keep trying, but now its worn in. Maybe you should try the same, but if it is an actual problem try contacting G&G : guay2.com

If that doesn't work contact pro airsoft supplies and if all else fails maybe go to a store where they can have a look at it?

 

Hope this helps and GL

Share this post


Link to post
Share on other sites

Thanks fellas, I went back to pro airsoft and the gun was repaired.Just got it back and it is SUPERB.

Share this post


Link to post
Share on other sites

Yeah, btw when you pull back the charging handle does anything happen? sometimes when I select semi after full auto it doesn't change back as well, charge a small niggle.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×