Jump to content

Archived

This topic is now archived and is closed to further replies.

kleedham

Help BB weight problem!

Recommended Posts

Hi. I have owned a 450 fps Warrior v3 l96 sniper for some time and i have been using .3g blaster bbs for it. These have been working ok but today i decided to buy .36 blaster devil bbs and the acuracy has gone from great to terrible. I can barely hit an apple at 15 meters with them. I thought heavier bbs were supposed to make the accuracy better. Any ideas?

Share this post


Link to post
Share on other sites

Did you adjust the hop up when using the heavier BB's?

Yes i did and it does go where i am aiming but in a huge spread nearly the size of my hand

Share this post


Link to post
Share on other sites

Go back to the 0.3s then.

Yeah thats what ive done but i was hoping for the accuracy and range of heavier bullets

Share this post


Link to post
Share on other sites

Probably something to do with the hop up unit not being able to either apply backspin properly or is not applying enough backspin. I've never seen or encountered this issue,however I'm willing to bet it's due to WELL's lack of QC.

Share this post


Link to post
Share on other sites

Probably something to do with the hop up unit not being able to either apply backspin properly or is not applying enough backspin. I've never seen or encountered this issue,however I'm willing to bet it's due to WELL's lack of QC.

Maybe your right what would you recomend to fix it

Share this post


Link to post
Share on other sites

New hop unit, rubber, barrel and barrel spacers should sort it, teflon taping the hop rubber and cylinder head will be beneficial too.

Share this post


Link to post
Share on other sites

New hop unit, rubber, barrel and barrel spacers should sort it, teflon taping the hop rubber and cylinder head will be beneficial too.

Thanks would you really think its the hop up. Thats working fine with .3s? I dont really know this has never happened to me before?

Share this post


Link to post
Share on other sites

Thanks would you really think its the hop up. Thats working fine with .3s? I dont really know this has never happened to me before?

Well that's a list of things that are very much worth doing regardless, it could be you're not getting enough hop applied. It seems strange that the heavier ones are less accurate though, not something I can really give reason for.

I'd suggest taking it apart and putting back together again- that tends to sort my problems :lol:

Share this post


Link to post
Share on other sites

Well that's a list of things that are very much worth doing regardless, it could be you're not getting enough hop applied. It seems strange that the heavier ones are less accurate though, not something I can really give reason for.

I'd suggest taking it apart and putting back together again- that tends to sort my problems :lol:

Thanks! ill get right on that

Share this post


Link to post
Share on other sites

Well that's a list of things that are very much worth doing regardless, it could be you're not getting enough hop applied. It seems strange that the heavier ones are less accurate though, not something I can really give reason for.

I'd suggest taking it apart and putting back together again- that tends to sort my problems :lol:

 

 

what he said! if you want to use heavier ammo your gonna have to upgrade internals otherwise your never going to get the accuracy/lift that you want.

Share this post


Link to post
Share on other sites

×