Jump to content
Sign in to follow this  
CaptainSwoop

M4 will only fire on Auto!

Recommended Posts

One of my M4s will only select auto,, Safety works but it is auto in both of the other positions.

WHen I stripped the gearbox shortly after I got it to check it out and refurb (it is an ex rental gun) everything looked ok.

I am wondering if the cut off has some wear on it that isn't obvious?

Share this post


Link to post
Share on other sites

The wear on the cutoff is really hard to see. You can screw the gearbox together without the spring and the cylinder and turn the gears with your finger. You'll see how much the cutoff moves. Then you can pull the trigger with your third hand and see if the cutoff can push the contact lever off from the trigger. :)

 

But the wear of the cutoff results more and more autofire in semi mode. So it's not like having a fine single fire and in the next moment full auto only. It's more like a few short bursts at first and it's getting worse gradually.

Check the selector plate and it's spring too.

Share this post


Link to post
Share on other sites

Had a similar problem after servicing my M16. Turns out the small spring between the fire selector plate and the cut off lever had dislodged so wasn't lifting the cut off. Works fine now its been replaced.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×