Jump to content

Archived

This topic is now archived and is closed to further replies.

Lowlander

WE BHP Help?

This thread is over three months old. Please be sure that your post is appropriate as it will revive this otherwise old (and probably forgotten) topic.

Recommended Posts

I have recently aquired a secondhand Browning Hi Power with three magazines and i have been having issues with it.

 

the problem is when I load a loaded and gassed mag it will fire the first round and immediately vent the rest of the gas. I have checked the valves and seals and not found any issues.

 

What Is interesting is that the gun cycles fine when the same magazines, unloaded but gassed are used.

 

Does anyone know whats going on here and how it can be fixed?

 

 

One of the magazines is also missing a little spring tab that has something to do with gas flow and blowback as the gun will not blowback without the tab present. it will however fire repeatedly abet with the need to manually cycle the next round. does anyone know where i might get one.

 

thanks

Share this post


Link to post
Share on other sites

Nobody able to help me?

Share this post


Link to post
Share on other sites

Strip the pistol down and give it a proper service, may not be anything to do with the mags, more likely something like the bbu

Share this post


Link to post
Share on other sites

I have done a full strip down of the pistol. As far as i can tell there is no damage to any of the parts. I re-lubricated the parts and have re-assembled. the blow back piston felt like it might be dragging a little. After reassembly the problem persists, the only way i found of temporarily solving the problem was to warm the magazines on the radiator before use, this would give me 8 or nine shots before it vented.

 

I am using green gas. would it be worth looking at propane?

Share this post


Link to post
Share on other sites

×
×
  • Create New...