Sign in to follow this  
Followers 0
onion

need help on my mp5 !!

25 posts in this topic

Hi people ,

just brought a tokyo marui mp5k pdw

is a amazing gun, but has a little problem sometimes , it will fire in full auto fine ... and if you go from full auto to semi it it normally fine , but sometimes in semi it just wont fire , i think it is a selector problem as sometimes it works and sometimes it doesnt ?

please let me no what you think , and were to get it fixed :P

thanks

Share this post


Link to post
Share on other sites

You best bet would be to e-mail the company you bought it from and ask them how to fix it or return it if it is still under warranty.

Share this post


Link to post
Share on other sites
i brought second hand ..

 

I had a similar problem with my MP5A4. I just removed the motor, selector switch etc and partially removed the grip so that the piece that moves the selector was out. Next, I pushed the plate on the gearbox all the way forward (to safety) and turned the piece to safety position. Then put it all back and it was fine.

Share this post


Link to post
Share on other sites

cheers il have a go , do you think a good retailer would be able to fix ?

Share this post


Link to post
Share on other sites

Yeah most rettailers have a tech guy who will be happy to fix it. If your not very good at that sort of thing it could save you alot of money, but if you think your up to the job go for it! :)

Share this post


Link to post
Share on other sites

i have always had m4s , im real confident with them , but mp5s , dont no were to start , probz find a vid on youtube...

cheers for that :)

Share this post


Link to post
Share on other sites

cheers for the vid ,

think im going to get it done by someone , as it looks quite complicated to me ..

Share this post


Link to post
Share on other sites

MP5K = PDW / Close range = Full auto,

 

save yourself the money its a common problem with V2/3 GB's

 

I shouldn't imagine you will need semi a lot with a weapon like that :)

Share this post


Link to post
Share on other sites

like matt said, youd be better off full auto since it a CQB gun, saves alot of time and money...

Share this post


Link to post
Share on other sites

[fair enoug hpoint , but i would rather have it working as it should , i cant imagine it will cost alot ?

Share this post


Link to post
Share on other sites

yeah , im going to take it skirmishing on sunday , the guys there no a fair bit so il let them have a look over it and give me a estamate :) cheers

Share this post


Link to post
Share on other sites

also some CQB sites are Semi only so it would be good to have it

Share this post


Link to post
Share on other sites

hehe i do know something about airsoft lol

Share this post


Link to post
Share on other sites

good news , sorted :) abit of tinkering and all fine now

Share this post


Link to post
Share on other sites

your selling it? thought you just got it?

Share this post


Link to post
Share on other sites

yeah , got a good deal on a different gun so going to get that ...

Share this post


Link to post
Share on other sites
If you could post up exactly what you did that'd be great for peoples' future reference. Then I can close the topic :)

 

what do you mean

Share this post


Link to post
Share on other sites
As in what process you went through to fix the problem.

 

watched the vid that you posted , then took it apart , whacked it back together , with a bit of silacone

works a treat :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0