Sign in to follow this  
Followers 0
JamieB

M4 firing problem

8 posts in this topic

Hi guys,

 

So i took my King Arms full metal M4 to a skirmish yesterday... and had a REALLY bad day. 8(

My stock fell off halfway through the morning, which was annoying. But also the gun (which is new) seems to have a recurring problem with the selector switch.

 

Basically, when it works it works well, on auto or semi, but when i flip the safety on it locks up. I can still move the selector switch to whatever position i want but i can't pull the trigger at all, so the guns is obviously still on safe. A couple of guys at the site helped me field strip it and put it back together, which got it working again, but as soon as i put it on safe after the next game it locked up AGAIN.

 

Brief history: I've had the gun for a few months but this is the first time i've skirmished it. Stock chrono'd at circa 400fps, so i had a guy from my local site install an m90 spring (now running at circa 300fps).

 

I tried installing a magpul moe pistol grip, which caused massive problems with motor height. Again, a guy from the site looked at it for me and sorted it out.

 

 

Any idea what could be causing the selector to get stuck on safe, and how can i fix it?

 

Thanks!

 

- jb

Share this post


Link to post
Share on other sites

mmmm..... sounds like a gearbox problem maybe? Best to have a local shop/experienced player have alook at it becuase gearbox work isnt a light hearted task

Share this post


Link to post
Share on other sites
mmmm..... sounds like a gearbox problem maybe? Best to have a local shop/experienced player have alook at it becuase gearbox work isnt a light hearted task

 

I've had the gearbox checked out by a local player and he said he couldn't spot any obvious damage or irregularities.. it's a mystery! I think the gun basically just hates me

Share this post


Link to post
Share on other sites

It might be either the selector plate (that is on the back side of the gearbox), or the safe pin inside the gearbox that it's not loose enough.

Field strip won't cut it, methinks.

 

If it has warranty, ask for a new one or the repair, or adventure yourself with the marvelous world of a V2 gearbox, and the annoying little springs.

Share this post


Link to post
Share on other sites
It might be either the selector plate (that is on the back side of the gearbox), or the safe pin inside the gearbox that it's not loose enough.

Field strip won't cut it, methinks.

 

If it has warranty, ask for a new one or the repair, or adventure yourself with the marvelous world of a V2 gearbox, and the annoying little springs.

 

That's pretty much the conclusion i got from guys at the site.. although no-one could see exactly what the problem was with just a quick look.

It most certainly doesn't have warranty, lol.

 

Maybe i'll use it as an excuse to learn about AEG gearboxes (and how to destroy them beyond repair, probably!!).

 

Other than mechbox.com is there anywhere else online that has info on sorting selector plate issues?

Share this post


Link to post
Share on other sites

Learn how to fieldstrip gearboxes on a King arms! are you serious :P those are expensive guns man :lol:

Share this post


Link to post
Share on other sites

I would Seirously advise you to hand it over.... but if you insist then Mechbox.com is the best place to go

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0