Callum Lol

M15A4 ###### up.

7 posts in this topic

Wondering if anyone else had this problem but, i bought a Classic Army M15A4 Sportline with a full stock recently and i ordered my battery a few days after, (Vapex 9.6v 3700mAh) fully charged it, attached the battery and slid it into the stock, and no firing, whatsoever.

I later find out the fuse has blown ¬_¬`

So i believe i need a higher fuse amp to cope with the battery?

And suggestions, or expierances?

Share this post


Link to post
Share on other sites

you shoud need a higher AMP fuse as that fuse matches the amp tollerance of the componets in the sircut

 

Just get a new fuse of the same type ;)

Share this post


Link to post
Share on other sites
you shoud need a higher AMP fuse as that fuse matches the amp tollerance of the componets in the sircut

 

Just get a new fuse of the same type ;)

 

I guessed right then ;)

 

Thank you :)

Share this post


Link to post
Share on other sites

NO NO NO WAIT!!!!!!!!!!!!!!!!!!!!!!!!!!!!! AAAAAARRRRRRGGGGGHHHHHHH

 

That was a typo i ment to say you SHOULDNT need a higher AMP fuse

Share this post


Link to post
Share on other sites

Just buy a set of 20A fuses from maplins, that is what I use.

Share this post


Link to post
Share on other sites
Just buy a set of 20A fuses from maplins, that is what I use.

 

Yeah i went there, but they only had 15A and i tried them all of them blew XD

Although i've ordered a pack of 30A and 35A online, as 20A clearly can't handle it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now